e10f0054a0b3aeb5969de7a8c9f87a05a107ceae
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-aodhclient_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "client library for Aodh built on the Aodh API"
17 HOMEPAGE = "https://launchpad.net/python-aodhclient"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 SRCREV = "6d03e61986418a3a95635405ae65ae9f28a5c61e"
23 SRCNAME = "python-aodhclient"
24 BRANCH = "stable/train"
25 PROTOCOL = "https"
26 PV = "1.2.0+git${SRCPV}"
27 S = "${WORKDIR}/git"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30         
31 inherit setuptools monitor rmargparse
32
33 DEPENDS += " \
34         python-pip \
35         python-pbr-native\
36         "
37
38 # Satisfy setup.py 'setup_requires'
39 DEPENDS += " \
40         python-pbr-native \
41         "
42
43 RDEPENDS_${PN} += " \
44         python-pbr \
45         python-cliff \
46         python-oslo.i18n \
47         python-oslo.serialization \
48         python-oslo.utils \
49         python-keystoneauth1 \
50         python-six \
51         python-osc-lib \
52         python-pyparsing \
53         "
54
55
56 do_install_append() {
57         :
58 }
59
60 FILES_${PN} += " \
61         "