build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-ansible_%.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 HOMEPAGE = "https://github.com/ansible/ansible/"
17 SECTION = "devel/python"
18 LICENSE = "GPLv3"
19 LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
20
21 PV = "2.8.5"
22
23 SRCNAME = "ansible"
24
25 SRC_URI = "http://releases.ansible.com/ansible/${SRCNAME}-${PV}.tar.gz"
26
27 SRC_URI[md5sum] = "86f0c18250895338709243d997005de3"
28 SRC_URI[sha256sum] = "8e9403e755ce8ef27b6066cdd7a4c567aa80ebe2fd90d0ff8efa0a725d246986"
29
30
31 S = "${WORKDIR}/${SRCNAME}-${PV}"
32
33 CLEANBROKEN = "1"
34
35 ANSIBLE_WHITELIST_MODULES = "  \
36         cloud \
37         clustering \
38         commands \
39         database \
40         files \
41         identity \
42         inventory \
43         messaging \
44         monitoring \
45         net_tools \
46         network \
47         notification \
48         packaging \
49         remote_management \
50         source_control \
51         storage \
52         system \
53         utilities \
54         web_infrastructure \
55         "