Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-amqp_2.5.2.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Low-level AMQP client for Python"
17 HOMEPAGE = "https://pypi.python.org/pypi/amqp/"
18 SECTION = "devel/python"
19 LICENSE = "BSD-3-Clause"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=9d6ba772ac59c08a25a12ce15bd5f27b"
21
22 SRC_URI[md5sum] = "852ecff645c00f124c78915fcc8ea7c0"
23 SRC_URI[sha256sum] = "77f1aef9410698d20eaeac5b73a87817365f457a507d82edf292e12cbb83b08d"
24
25 PYPI_PACKAGE = "amqp"
26 inherit setuptools pypi
27
28 RDEPENDS_${PN} += " \
29         python-vine \
30         "