Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-adal_1.0.2.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Microsoft Azure Active Directory Authentication Library (ADAL) for Python"
17 HOMEPAGE = "https://github.com/AzureAD/azure-activedirectory-library-for-python"
18 SECTION = "devel/python"
19 LICENSE = "MIT"
20 LIC_FILES_CHKSUM = "file://setup.py;beginline=2;endline=27;md5=43b81fae9d7baa1f0b1c9774a68ca33a"
21
22
23 inherit pypi setuptools
24
25 PYPI_PACKAGE = "adal"
26
27 SRC_URI[md5sum] = "895791621c696fbbb00dee975260f890" 
28 SRC_URI[sha256sum] = "4c020807b3f3cfd90f59203077dd5e1f59671833f8c3c5028ec029ed5072f9ce"
29
30 RDEPENDS_${PN} += " \
31         ${PYTHON_PN}-requests \
32         ${PYTHON_PN}-dateutil \
33         ${PYTHON_PN}-pyjwt \
34         ${PYTHON_PN}-crypt \
35         ${PYTHON_PN}-datetime \
36         ${PYTHON_PN}-json \
37         ${PYTHON_PN}-logging \
38         ${PYTHON_PN}-netclient \
39         ${PYTHON_PN}-threading \
40         ${PYTHON_PN}-xml \
41         "