Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / perl / scalar-list-utils-perl_1.50.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "A selection of general-utility list subroutines"
17 DESCRIPTION = "\
18   List::Util contains a selection of subroutines that people have expressed \
19   would be nice to have in the perl core, but the usage would not really be \
20   high enough to warrant the use of a keyword, and the size so small such \
21   that being individual extensions would be wasteful.\
22 "
23 HOMEPAGE= "https://metacpan.org/release/Scalar-List-Utils"
24
25 SECTION = "libs"
26
27 LICENSE = "Artistic-1.0 | GPL-1.0+"
28
29 LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
30
31 CPAN_PACKAGE = "Scalar-List-Utils"
32
33 SRC_URI = "${CPAN_MIRROR}/authors/id/P/PE/PEVANS/${CPAN_PACKAGE}-${PV}.tar.gz"
34
35 SRC_URI[md5sum] = "136313884d1afa2fb6840695a1034b2c"
36 SRC_URI[sha256sum] = "06aab9c693380190e53be09be7daed20c5d6278f71956989c24cca7782013675"
37
38 S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
39
40 inherit cpan
41
42 BBCLASSEXTEND = "native nativesdk"