Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / perl / podlators-perl_4.12.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "format POD source into various output formats"
17 DESCRIPTION = "\
18   podlators contains Pod::Man and Pod::Text modules which convert POD input \
19   to *roff source output, suitable for man pages, or plain text. It also \
20   includes several subclasses of Pod::Text for formatted output to terminals \
21   with various capabilities. It is the source package for the Pod::Man and \
22   Pod::Text modules included with Perl. \
23 "
24 HOMEPAGE = "https://www.eyrie.org/~eagle/software/podlators"
25
26 SECTION = "libs"
27
28 LICENSE = "Artistic-1.0 | GPL-1.0+"
29 LIC_FILES_CHKSUM = "file://LICENSE;md5=a25b3c873fe34dc2909a5b1ca2de4048"
30
31 CPAN_PACKAGE = "podlators"
32
33 SRC_URI = "${CPAN_MIRROR}/authors/id/R/RR/RRA/${CPAN_PACKAGE}-${PV}.tar.gz"
34
35 SRC_URI[md5sum] = "99d5b0c15d2f72c5218dce1a5a9448c5"
36 SRC_URI[sha256sum] = "948717da19630a5f003da4406da90fe1cbdec9ae493671c90dfb6d8b3d63b7eb"
37
38 S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
39
40 inherit cpan
41
42 RDEPENDS_${PN} = " \
43     perl-module-encode \
44     perl-module-pod-simple \
45 "
46
47 BBCLASSEXTEND = "native nativesdk"