Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / perl / pathtools-perl_3.75.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Tools for working with directory and file names"
17 DESCRIPTION = "\
18   Modules included: \
19     - Cwd - get pathname of current working directory \
20     - File::Spec - portably perform operations on file names \
21     - File::Spec::AmigaOS - File::Spec for AmigaOS \
22     - File::Spec::Cygwin - methods for Cygwin file specs \
23     - File::Spec::Epoc - methods for Epoc file specs \
24     - File::Spec::Functions - portably perform operations on file names \
25     - File::Spec::Mac - File::Spec for Mac OS (Classic) \
26     - File::Spec::OS2 - methods for OS/2 file specs \
27     - File::Spec::Unix - File::Spec for Unix, base for other File::Spec modules \
28     - File::Spec::VMS - methods for VMS file specs \
29     - File::Spec::Win32 - methods for Win32 file specs \
30 "
31 HOMEPAGE = "https://metacpan.org/release/PathTools"
32
33 SECTION = "libs"
34
35 LICENSE = "Artistic-1.0 | GPL-1.0+"
36 LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
37
38 CPAN_PACKAGE = "PathTools" 
39
40 SRC_URI = "${CPAN_MIRROR}/authors/id/X/XS/XSAWYERX/${CPAN_PACKAGE}-${PV}.tar.gz"
41
42 SRC_URI[md5sum] = "8f329058f74468a576442d841c62aa62"
43 SRC_URI[sha256sum] = "a558503aa6b1f8c727c0073339081a77888606aa701ada1ad62dd9d8c3f945a2"
44
45 S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
46
47 inherit cpan
48
49 RDEPENDS_${PN} = " \
50     perl-module-carp \
51     perl-module-file-basename \
52     perl-module-scalar-util \
53     perl-module-test-more \
54 "
55
56 BBCLASSEXTEND = "native nativesdk"