Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / perl / libwww-perl_6.35.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "libwww-perl provides a simple and consistent API to the World Wide Web"
17 HOMEPAGE = "https://metacpan.org/release/libwww-perl"
18 SECTION = "libs"
19 LICENSE = "Artistic-1.0 | GPL-1.0+"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=225d44a95fa3addb1da6d91187ab189f"
21 DEPENDS = "liburi-perl-native libhtml-parser-perl-native libhtml-tagset-perl-native"
22 RDEPENDS_${PN} += " \
23         libhtml-parser-perl \
24         libhtml-tagset-perl \
25         liburi-perl \
26         perl-module-digest-md5 \
27         perl-module-net-ftp \
28         "
29 BBCLASSEXTEND = "native"
30
31
32 SRC_URI = "https://cpan.metacpan.org/authors/id/E/ET/ETHER/libwww-perl-${PV}.tar.gz;name=libwww-perl-${PV}"
33 SRC_URI[libwww-perl-6.35.md5sum] = "19cd0f55f61359c973caa9301ec405bd"
34 SRC_URI[libwww-perl-6.35.sha256sum] = "dda2578d7b32152c4afce834761a61d117de286c705a9f7972c7ac6032ca5953"
35
36 S = "${WORKDIR}/libwww-perl-${PV}"
37
38 inherit cpan