build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-devtools / perl / libwww-perl_6.05.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "libwww-perl provides a simple and consistent API to the World Wide Web"
17 HOMEPAGE = "http://search.cpan.org/dist/libwww-perl/"
18 SECTION = "libs"
19 LICENSE = "Artistic-1.0 | GPL-1.0+"
20 LIC_FILES_CHKSUM = "file://README;beginline=92;endline=98;md5=3da13bc02f8f17ed35ac5d192cae6fe4"
21 DEPENDS = "liburi-perl-native libhtml-parser-perl-native libhtml-tagset-perl-native"
22 RDEPENDS_${PN} += " \
23         libhtml-parser-perl \
24         libhtml-tagset-perl \
25         liburi-perl \
26         perl-module-digest-md5 \
27         perl-module-net-ftp \
28         "
29 BBCLASSEXTEND = "native"
30
31
32 SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/libwww-perl-${PV}.tar.gz;name=libwww-perl-${PV}"
33 SRC_URI[libwww-perl-6.05.md5sum] = "637d5f1eb61336ca2caa6e026b382f87"
34 SRC_URI[libwww-perl-6.05.sha256sum] = "7b25799ff7eec18e8e4e97dc0cad7b2a5b433b50b13feb59d9179173bee78f23"
35
36 S = "${WORKDIR}/libwww-perl-${PV}"
37
38 inherit cpan
39