Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / perl / libmailtools-perl_2.20.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "MailTools is a set of Perl modules related to mail applications"
17 HOMEPAGE = "http://search.cpan.org/dist/MailTools/"
18 SECTION = "libs"
19 LICENSE = "Artistic-1.0 | GPL-1.0+"
20 LIC_FILES_CHKSUM = "file://lib/Mail/Mailer.pod;beginline=144;md5=641bd171b1aaabba1fc83ac0a98a2d30"
21 DEPENDS = " \
22         libtest-pod-perl-native \
23         libtimedate-perl-native \
24         "       
25 RDEPENDS_${PN} += " \
26         libtest-pod-perl \
27         libtimedate-perl \
28         perl-module-io-handle \
29         perl-module-net-smtp \
30         perl-module-test-more \
31         "
32 BBCLASSEXTEND = "native"
33
34 SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/MailTools-${PV}.tar.gz"
35 SRC_URI[md5sum] = "53e9d35256c3fd7cef0e4a24b15e9512"
36 SRC_URI[sha256sum] = "f55606f7a9cc342ee9d5f996e2b6a4c0047e2ee47cd88c3250ecf0d0c5fb3196"
37
38 S = "${WORKDIR}/MailTools-${PV}"
39
40 inherit cpan