Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / perl / filter-perl_1.59.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "perlfilter - Source Filters"
17 DESCRIPTION = "\
18   perlfilter - Source Filters \
19     Modules included: \
20     - Filter::Util::Call - Perl Source Filter Utility Module \
21     - Filter::Util::Exec - exec source filter \
22     - Filter::decrypt - template for a decrypt source filter \
23     - Filter::cpp - cpp source filter \
24     - Filter::exec - exec source filter \
25     - Filter::m4 - M4 source filter \
26     - Filter::sh - sh source filter \
27     - Filter::tee - tee source filter \
28 "
29 HOMEPAGE = "https://metacpan.org/release/Filter"
30
31 SECTION = "libs"
32
33 LICENSE = "Artistic-1.0 | GPL-1.0+"
34 LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
35
36 CPAN_PACKAGE = "Filter"
37
38 SRC_URI = "${CPAN_MIRROR}/authors/id/R/RU/RURBAN/${CPAN_PACKAGE}-${PV}.tar.gz"
39
40 SRC_URI[md5sum] = "54e08a158bff1f35e0a93b3993dcf52f"
41 SRC_URI[sha256sum] = "b4babfad4e0566a9a61199735f6e622a60d3274122752304f18f623412bf4e5a"
42
43 S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
44
45 inherit cpan
46
47 BBCLASSEXTEND = "native nativesdk"