build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-devtools / json-c / json-c_0.11.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "C bindings for apps which will manipulate JSON data"
17 DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
18 HOMEPAGE = "https://github.com/json-c/json-c/wiki"
19 LICENSE = "MIT"
20 LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
21
22 SRC_URI = "\
23     https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
24     file://json-c-CVE-2013-6371.patch \
25     file://json-c-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch \
26 "
27 SRC_URI[md5sum] = "aa02367d2f7a830bf1e3376f77881e98"
28 SRC_URI[sha256sum] = "28dfc65145dc0d4df1dfe7701ac173c4e5f9347176c8983edbfac9149494448c"
29
30 RPROVIDES_${PN} = "libjson"
31
32 PARALLEL_MAKE = ""
33
34 inherit autotools
35
36 do_configure_prepend() {
37     # Clean up autoconf cruft that should not be in the tarball
38     rm -f ${S}/config.status
39 }
40
41 BBCLASSEXTEND = "native nativesdk"