Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / go / go-phercloud_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "an OpenStack SDK for Go"
17 HOMEPAGE = "https://github.com/gophercloud/gophercloud"
18 SECTION = "devel/go"
19 LICENSE = "MIT"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=dd19699707373c2ca31531a659130416"
21
22 SRCNAME = "gophercloud"
23
24 PKG_NAME = "github.com/gophercloud/${SRCNAME}"
25 SRC_URI = "git://${PKG_NAME}.git"
26
27 SRCREV = "aa00757ee3ab58e53520b6cb910ca0543116400a"
28 PV = "0.3.0+git${SRCREV}"
29 RDEPENDS_${PN} = "bash"
30 S = "${WORKDIR}/git"
31
32 do_install() {
33         install -d ${D}${prefix}/local/go/src/${PKG_NAME}
34         cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
35 }
36
37 SYSROOT_PREPROCESS_FUNCS += "go_phercloud_sysroot_preprocess"
38
39 go_phercloud_sysroot_preprocess () {
40     install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
41     cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
42 }
43
44 FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"