Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / erlang / erlang_R16B03-1.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17
18 # erlang < 20.0 is not compatibel with OpenSSL 1.1.x
19 inherit openssl10
20
21 SRC_URI += " \
22         file://fix-install-ownership.patch \
23         "
24
25 EXTRA_OECONF = '--with-ssl=${STAGING_DIR_TARGET}/usr --without-krb5 --without-zlib'
26
27 do_configure_prepend () {
28     export erl_xcomp_sysroot="${STAGING_DIR_HOST}/usr"
29     export erl_xcomp_isysroot="${STAGING_DIR_NATIVE}"
30
31     sed -i -e 's/opensslconf.h/opensslconf-64.h/' \
32         ${STAGING_INCDIR}/openssl10/openssl/rc4.h \
33         ${STAGING_INCDIR}/openssl10/openssl/rc2.h
34 }
35
36 do_install_append () {
37     # Fix the do_package_qa issue
38     chown -R root:root ${D}
39 }