Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-dbs / mysql / mysql-python_1.2.5.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Python interface to MySQL"
17 HOMEPAGE = "https://github.com/farcepest/MySQLdb1"
18 SECTION = "devel/python"
19 LICENSE = "GPLv2"
20 LIC_FILES_CHKSUM = "file://GPL-2.0;md5=b234ee4d69f5fce4486a80fdaf4a4263"
21
22 DEPENDS = "mysql5"
23
24 SRCNAME = "MySQL-python"
25
26 SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.zip \
27            file://0001-_mysql.c-fix-compilation-with-MariaDB-with-10.3.13.patch \
28 "
29 SRC_URI[md5sum] = "654f75b302db6ed8dc5a898c625e030c"
30 SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e140c74"
31
32 S = "${WORKDIR}/${SRCNAME}-${PV}"
33
34 inherit setuptools