Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-daemons / lldpd / lldpd_%.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/patches:${THISDIR}/files:"
17
18 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
19
20 SRC_URI += " \
21         file://0001-lldpd-client-add-show-interfaces-cmd-from-upstream.patch \
22         file://0002-Clear-station-bit-if-any-other-capability-is-enabled.patch \
23         file://i40e-lldp-configure.sh \
24         "
25
26 # TODO: 
27 # Check Yocto handling of i40e firmware?
28 # See i40e-lldp-configure.sh and lldpd-i40e-disable.patch
29
30 # file://lldpd.init 
31 # lldpd-create-run-dir.patch
32
33 do_install_append() {
34         cd ${S}
35         install -d -m 0755 ${D}/${sysconfdir}/init.d
36         install -m 0755 ${WORKDIR}/i40e-lldp-configure.sh ${D}/${sysconfdir}/init.d/
37 }
38
39 FILES_${PN}_append = " \
40         ${sysconfdir}/init.d/i40e-lldp-configure.sh \
41         "
42
43 RDEPENDS_${PN} += "bash"