systemd: remove the log message about /var/run
[pti/rtp.git] / meta-stx / recipes-core / systemd / systemd_241.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17
18 SRC_URI += " \
19         file://0900-inject-milisec-in-syslog-date.patch \
20         file://0001-systemd-remove-the-log-about-var-run.patch \
21         "
22
23 STX_DEFAULT_LOCALE ?= "en_US.UTF-8"
24
25 do_install_append () {
26         install -d ${D}${sysconfdir}
27         echo LANG=${STX_DEFAULT_LOCALE} >> ${D}${sysconfdir}/locale.conf
28 }
29
30 FILES_${PN} += "${sysconfdir}/locale.conf"