stx-utilities: inherit systemd to enable services
[pti/rtp.git] / meta-stx / recipes-core / stx-utilities / stx-utilities_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-utilities"
17
18 PROTOCOL = "https"
19 SRCNAME = "utilities"
20 BRANCH = "r/stx.3.0"
21 SRCREV = "cbad6b792157d066dd601f0f9ce62dc177d4c848"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25 LICENSE = "Apache-2.0"
26
27 #e7b3e2a120f5d4c0f6f562a52b6badf4  ./security/tpm2-openssl-engine/tpm2-openssl-engine/LICENSE
28 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/build-info/build-info-1.0/LICENSE
29 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/namespace-utils/LICENSE
30 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/namespace-utils/namespace-utils/LICENSE
31 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/nfscheck/LICENSE
32 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/nfscheck/files/LICENSE
33 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/pci-irq-affinity-agent/files/LICENSE
34 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/platform-util/platform-util/LICENSE
35 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/platform-util/scripts/LICENSE
36 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/stx-extensions/files/LICENSE
37 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/update-motd/LICENSE
38 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/update-motd/files/LICENSE
39 #3b83ef96387f14655fc854ddc3c6bd57  ./utilities/worker-utils/worker-utils/LICENSE
40
41 LIC_FILES_CHKSUM = " \
42         file://ceph/ceph-manager/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
43         file://ceph/python-cephclient/python-cephclient/LICENSE;md5=41687b590435621fc0676ac02c51154f \
44         file://security/stx-ssl/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
45         file://tools/collector/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
46         file://tools/collector/scripts/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
47         file://tools/engtools/hostdata-collectors/scripts/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
48         file://utilities/logmgmt/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
49         file://utilities/logmgmt/logmgmt/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
50         "
51
52
53 SRC_URI = " \
54         git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
55         "
56
57 inherit setuptools distutils python-dir systemd
58 DEPENDS = " \
59         python-pip \
60         python-pbr-native \
61         systemd \
62 "
63
64 require utilities/build-info.inc
65 require utilities/logmgmt.inc
66 require utilities/namespace-utils.inc
67 require utilities/nfscheck.inc
68 require utilities/pci-irq-affinity.inc
69 require utilities/platform-util.inc
70 require utilities/stx-extensions.inc
71 require utilities/update-motd.inc
72 require utilities/worker-utils.inc
73 require ceph/ceph-manager.inc
74 require ceph/python-cephclient.inc
75 require security/stx-ssl.inc
76 # Skip tpm2-openssl-engine2
77 require tools/collector.inc
78 require tools/collect-engtools.inc
79
80 do_configure() {
81         :
82 }
83
84 do_compile() {
85         :
86 }
87
88 do_install() {
89         :
90 }
91
92 FILES_${PN} = " "
93
94 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"