Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-upstream / openstack-ras_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Pacemaker High Availability resource agents for OpenStack"
17 SUMMARY = "Openstack Resource Agents from Madkiss"
18
19 PROTOCOL = "https"
20 BRANCH = "stable-grizzly"
21 SRCNAME = "openstack-resource-agents"
22 SRCREV = "6db39a959438326ef16ae671f02ebbce22309e21"
23 S = "${WORKDIR}/git"
24 PV = "1.0.0"
25
26 LICENSE = "Apache-2.0"
27 LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
28
29 SRC_URI = "git://github.com/madkiss/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 do_configure() {
32         :
33 }
34
35
36 do_compile() {
37         :
38 }
39
40
41 do_install() {
42         make  DESTDIR=${D} install
43         rm -rf ${D}/usr/lib/ocf/resource.d/openstack/ceilometer-agent-central
44         rm -rf ${D}/usr/lib/ocf/resource.d/openstack/ceilometer-alarm-evaluator
45         rm -rf ${D}/usr/lib/ocf/resource.d/openstack/ceilometer-alarm-notifier
46 }
47
48 FILES_${PN} += " ${libdir}"