openstack-ras: change the source repo from starlingx
[pti/rtp.git] / meta-stx / recipes-core / stx-upstream / openstack-ras_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Pacemaker High Availability resource agents for OpenStack"
17 SUMMARY = "Openstack Resource Agents from Madkiss"
18
19 PROTOCOL = "https"
20 BRANCH = "master"
21 SRCREV = "cc6f677570b4f0e7ba44a91d5dff33164b8b76bc"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25 LICENSE = "Apache-2.0"
26 LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
27
28 SRC_URI = "git://github.com/starlingx-staging/stx-openstack-ras.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
29
30 do_configure() {
31         :
32 }
33
34
35 do_compile() {
36         :
37 }
38
39
40 do_install() {
41         make  DESTDIR=${D} install
42         rm -rf ${D}/usr/lib/ocf/resource.d/openstack/ceilometer-agent-central
43         rm -rf ${D}/usr/lib/ocf/resource.d/openstack/ceilometer-alarm-evaluator
44         rm -rf ${D}/usr/lib/ocf/resource.d/openstack/ceilometer-alarm-notifier
45 }
46
47 FILES_${PN} += " ${libdir}"