stx-update: backport a patch to remove dependency on yum
[pti/rtp.git] / meta-stx / recipes-core / stx-update / stx-update.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-update"
17
18 PROTOCOL = "https"
19 BRANCH = "r/stx.3.0"
20 SRCREV = "2542c5539bab060830009d02cbb257cc8bf4a376"
21 S = "${WORKDIR}/git"
22 PV = "1.0.0"
23
24 LICENSE = "Apache-2.0"
25
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
27
28 SRC_URI = " \
29         git://opendev.org/starlingx/update.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
30         file://0001-Remove-use-of-rpmUtils.miscutils-from-cgcs-patch.patch \
31         "
32
33 DEPENDS = " \
34         python \
35         python-pbr-native \
36         "
37
38 RDEPENDS_${PN} += " python-requests-toolbelt"
39
40 require cgcs-patch.inc
41 require enable-dev-patch.inc
42 require patch-alarm.inc
43
44 do_configure () {
45         :
46
47
48 do_compile() {
49         :
50 }
51
52 do_install () {
53         :
54 }
55
56 pkg_postinst_ontarget_${PN} () { 
57 }
58
59 FILES_${PN} = " "