2412e18c883e75f1ac89748068c441c4f1f5747c
[pti/rtp.git] / meta-stx / recipes-core / stx-update / stx-update.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-update"
17
18 PROTOCOL = "https"
19 BRANCH = "r/stx.3.0"
20 SRCREV = "2542c5539bab060830009d02cbb257cc8bf4a376"
21 S = "${WORKDIR}/git"
22 PV = "1.0.0"
23
24 LICENSE = "Apache-2.0"
25
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
27
28 SRC_URI = "git://opendev.org/starlingx/update.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
29
30 DEPENDS = " \
31         python \
32         python-pbr-native \
33         "
34
35 RDEPENDS_${PN} += " python-requests-toolbelt"
36
37 require cgcs-patch.inc
38 require enable-dev-patch.inc
39 require patch-alarm.inc
40
41 do_configure () {
42         :
43
44
45 do_compile() {
46         :
47 }
48
49 do_install () {
50         :
51 }
52
53 pkg_postinst_ontarget_${PN} () { 
54 }
55
56 FILES_${PN} = " "