Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-nfv / stx-nfv.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-nfv"
17
18 PROTOCOL = "https"
19 BRANCH = "r/stx.3.0"
20 SRCREV = "aaa932c00e028dcbaf0eed6843c4d3e51f09b2c1"
21 S = "${WORKDIR}/git"
22 PV = "1.0.0"
23
24 LICENSE = "Apache-2.0"
25
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
27
28
29 SRC_URI = "git://opendev.org/starlingx/nfv.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
30         file://use-ldflags-mtce-guest.patch \
31         "
32
33 DEPENDS += " \
34         python \
35         python-pbr-native \
36         stx-metal \
37         stx-fault \
38         json-c \
39         openssl \
40         libevent \
41         libgcc \
42         "
43
44 require mtce-guest.inc
45 require nfv-vim.inc
46 require nfv-common.inc
47 require nfv-client.inc
48 require nfv-plugins.inc
49 require nfv-tools.inc
50 require nova-api-proxy.inc
51
52 do_configure () {
53         :
54
55
56 do_compile() {
57         :
58 }
59
60 do_install () {
61         :
62 }
63
64 pkg_postinst_ontarget_${PN} () {
65 }
66
67 FILES_${PN} = " "