build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-core / stx-monitoring / stx-monitoring.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-monitoring"
17
18 PROTOCOL = "https"
19 BRANCH = "r/stx.3.0"
20 SRCNAME = "monitoring"
21 SRCREV = "8befe1720b02c5e1e3ddf637947643b9b0a0f96f"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25 LICENSE = "Apache-2.0"
26
27 LIC_FILES_CHKSUM = " \
28         file://collectd-extensions/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
29         file://influxdb-extensions/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
30         file://monitor-tools/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
31         file://monitor-tools/scripts/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
32         file://vm-topology/vm-topology/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
33         "
34
35 SRC_URI = "git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
36
37 DEPENDS += " \
38         python \
39         python-pbr-native \
40         stx-metal \
41         stx-fault \
42         json-c \
43         openssl \
44         libevent \
45         libgcc \
46         "
47
48 require collectd-extensions.inc
49 require influxdb-extensions.inc
50 require monitor-tools.inc
51 require vm-topology.inc
52
53 do_configure () {
54         :
55
56
57 do_compile() {
58         :
59 }
60
61 do_install () {
62         :
63 }
64
65 pkg_postinst_ontarget_${PN} () {
66 }
67
68 FILES_${PN} = " "