8414d5fa528903000a263aabceac5b5e57daf651
[pti/rtp.git] / meta-stx / recipes-core / stx-monitoring / stx-monitoring.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-monitoring"
17
18 PROTOCOL = "https"
19 BRANCH = "r/stx.3.0"
20 SRCNAME = "monitoring"
21 SRCREV = "8befe1720b02c5e1e3ddf637947643b9b0a0f96f"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25 LICENSE = "Apache-2.0"
26
27 # TODO:
28 #3b83ef96387f14655fc854ddc3c6bd57  ./collectd-extensions/src/LICENSE
29 #3b83ef96387f14655fc854ddc3c6bd57  ./influxdb-extensions/src/LICENSE
30 #3b83ef96387f14655fc854ddc3c6bd57  ./monitor-tools/LICENSE
31 #3b83ef96387f14655fc854ddc3c6bd57  ./monitor-tools/scripts/LICENSE
32 #3b83ef96387f14655fc854ddc3c6bd57  ./vm-topology/vm-topology/LICENSE
33
34 LIC_FILES_CHKSUM = "file://collectd-extensions/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
35
36 SRC_URI = "git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
37
38 DEPENDS += " \
39         python \
40         python-pbr-native \
41         stx-metal \
42         stx-fault \
43         json-c \
44         openssl \
45         libevent \
46         libgcc \
47         "
48
49 require collectd-extensions.inc
50 require influxdb-extensions.inc
51 require monitor-tools.inc
52 require vm-topology.inc
53
54 do_configure () {
55         :
56
57
58 do_compile() {
59         :
60 }
61
62 do_install () {
63         :
64 }
65
66 pkg_postinst_ontarget_${PN} () {
67 }
68
69 FILES_${PN} = " "