Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-monitor-armada-app / stx-monitor-helm_1.0.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "StarlingX Monitor Application Armada Helm Charts"
17 DESCRIPTION = "StarlingX Monitor Application Armada Helm Charts"
18
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
21
22 DEPENDS += " \
23     monitor-helm \
24     monitor-helm-elastic \
25 "
26
27 PROTOCOL = "https"
28 BRANCH = "r/stx.3.0"
29 SRCREV = "e5ee6b3a07b74479b93fe90eff0662cf81890f73"
30
31 SRC_URI = "git://opendev.org/starlingx/monitor-armada-app.git;protocol=${PROTOCOL};branch=${BRANCH}"
32
33 S = "${WORKDIR}/git/stx-monitor-helm/stx-monitor-helm"
34
35 inherit allarch
36
37 helm_folder = "${nonarch_libdir}/helm"
38 armada_folder = "${nonarch_libdir}/armada"
39 app_folder = "${nonarch_libdir}/application"
40
41 do_configure () {
42         :
43 }
44
45 do_compile () {
46         :
47 }
48
49 do_install () {
50         install -d -m 755 ${D}${armada_folder}
51         install -p -D -m 755 ${S}/manifests/*.yaml ${D}${armada_folder}
52         install -d -m 755 ${D}${app_folder}
53         install -p -D -m 755 ${S}/files/metadata.yaml ${D}${app_folder}/monitor_metadata.yaml
54 }
55
56 FILES_${PN} = " \
57     ${app_folder} \
58     ${armada_folder} \
59 "
60
61 RDEPENDS_${PN} = " \
62     helm \
63     monitor-helm \
64     monitor-helm-elastic \
65 "