pmon: send pulse to hostwd under polling mode
[pti/rtp.git] / meta-stx / recipes-core / stx-metal / stx-metal.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-metal"
17
18 # STABLE = "starlingx/master"
19 PROTOCOL = "https"
20 BRANCH = "r/stx.3.0"
21 SRCREV = "be3cf4eeb50eef55910cf9c73ea47c168005ad64"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25 LICENSE = "Apache-2.0"
26 LIC_FILES_CHKSUM = " \
27         file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
28         file://installer/pxe-network-installer/pxe-network-installer/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
29         file://kickstart/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
30         file://mtce-common/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
31         file://mtce-compute/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
32         file://mtce-control/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
33         file://mtce-storage/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
34         file://mtce/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
35         file://inventory/inventory/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
36         file://python-inventoryclient/inventoryclient/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
37         "
38
39
40 SRC_URI = "git://opendev.org/starlingx/metal.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
41                 file://0001-mtce-compute-dont-install-empty-directory-unless-nee.patch \
42                 file://0001-mtce-control-dont-install-empty-directory-unless-nee.patch \
43                 file://0001-mtce-storage-dont-install-empty-directory-unless-nee.patch \
44                 file://0001-Use-snprintf-to-avoid-overflowing-amon.tx_buf.patch \
45                 file://0001-Use-LDFLAGS-when-linking-and-pass-flags-down-to-subm.patch \
46                 file://0001-stx-metal-remove-argparse-requirement-from-inventory.patch \
47                 file://stx-warrior-adjust-paths.patch \
48                 file://pmon_send_pulse.patch \
49                 "
50
51 inherit setuptools systemd
52
53
54 DEPENDS = " \
55         python \
56         python-pbr-native \
57         stx-fault \
58         openssl \
59         libevent \
60         json-c \
61         "
62 RDEPENDS_${PN}_append = " bash"
63
64 require mtce.inc
65 require inventory.inc
66 require mtce-common.inc
67 require mtce-compute.inc
68 require mtce-control.inc
69 require mtce-storage.inc
70 require python-inventoryclient.inc
71 require pxe-network-installer.inc
72 # require kickstart.inc
73
74 do_configure () {
75         :
76
77
78 do_compile() {
79         :
80 }
81
82 do_install () {
83         :
84 }
85
86 pkg_postinst_ontarget_${PN} () {
87 # install default config files
88 }
89
90 FILES_${PN} = " "
91 FILES_${PN}-dbg_append += " "
92 FILES_${PN}-staticdev_append = " "
93 FILES_${PN}-dev_append = " "
94
95 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"