712256582bdf6f2977b23a5161723b300068c70f
[pti/rtp.git] / meta-stx / recipes-core / stx-metal / stx-metal.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-metal"
17
18 # STABLE = "starlingx/master"
19 PROTOCOL = "https"
20 BRANCH = "r/stx.3.0"
21 SRCREV = "be3cf4eeb50eef55910cf9c73ea47c168005ad64"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25 LICENSE = "Apache-2.0"
26 LIC_FILES_CHKSUM = " \
27         file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
28         file://installer/pxe-network-installer/pxe-network-installer/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
29         file://kickstart/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
30         file://mtce-common/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
31         file://mtce-compute/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
32         file://mtce-control/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
33         file://mtce-storage/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
34         file://mtce/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
35         file://inventory/inventory/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
36         file://python-inventoryclient/inventoryclient/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
37         "
38
39
40 SRC_URI = "git://opendev.org/starlingx/metal.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
41                 file://0001-mtce-compute-dont-install-empty-directory-unless-nee.patch \
42                 file://0001-mtce-control-dont-install-empty-directory-unless-nee.patch \
43                 file://0001-mtce-storage-dont-install-empty-directory-unless-nee.patch \
44                 file://0001-Use-snprintf-to-avoid-overflowing-amon.tx_buf.patch \
45                 file://0001-Use-LDFLAGS-when-linking-and-pass-flags-down-to-subm.patch \
46                 file://0001-stx-metal-remove-argparse-requirement-from-inventory.patch \
47                 file://stx-warrior-adjust-paths.patch \
48                 "
49
50 inherit setuptools systemd
51
52
53 DEPENDS = " \
54         python \
55         python-pbr-native \
56         stx-fault \
57         openssl \
58         libevent \
59         json-c \
60         "
61 RDEPENDS_${PN}_append = " bash"
62
63 require mtce.inc
64 require inventory.inc
65 require mtce-common.inc
66 require mtce-compute.inc
67 require mtce-control.inc
68 require mtce-storage.inc
69 require python-inventoryclient.inc
70 require pxe-network-installer.inc
71 # require kickstart.inc
72
73 do_configure () {
74         :
75
76
77 do_compile() {
78         :
79 }
80
81 do_install () {
82         :
83 }
84
85 pkg_postinst_ontarget_${PN} () {
86 # install default config files
87 }
88
89 FILES_${PN} = " "
90 FILES_${PN}-dbg_append += " "
91 FILES_${PN}-staticdev_append = " "
92 FILES_${PN}-dev_append = " "
93
94 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"