14421969cc79bef0fb93465c28bca9d61adaa635
[pti/rtp.git] / meta-stx / recipes-core / stx-metal / stx-metal.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-metal"
17
18 # STABLE = "starlingx/master"
19 PROTOCOL = "https"
20 BRANCH = "r/stx.3.0"
21 SRCREV = "be3cf4eeb50eef55910cf9c73ea47c168005ad64"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25 LICENSE = "Apache-2.0"
26 LIC_FILES_CHKSUM = " \
27         file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
28         file://installer/pxe-network-installer/pxe-network-installer/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
29         file://kickstart/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
30         file://mtce-common/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
31         file://mtce-compute/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
32         file://mtce-control/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
33         file://mtce-storage/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
34         file://mtce/src/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
35         file://inventory/inventory/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
36         file://python-inventoryclient/inventoryclient/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
37         "
38
39
40 SRC_URI = "git://opendev.org/starlingx/metal.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
41         file://0001-mtce-compute-dont-install-empty-directory-unless-nee.patch \
42         file://0002-mtce-control-dont-install-empty-directory-unless-nee.patch \
43         file://0003-mtce-storage-dont-install-empty-directory-unless-nee.patch \
44         file://0004-Use-snprintf-to-avoid-overflowing-amon.tx_buf.patch \
45         file://0005-Use-LDFLAGS-when-linking-and-pass-flags-down-to-subm.patch \
46         file://0006-stx-metal-remove-argparse-requirement-from-inventory.patch \
47         file://0007-mtce-do-not-use-which-to-check-CC.patch \
48         file://0008-stx-warrior-adjust-paths.patch \
49         file://0009-pmon_send_pulse.patch \
50         file://0010-libamon-add-shared-option.patch \
51         "
52
53 inherit setuptools systemd
54
55
56 DEPENDS = " \
57         python \
58         python-pbr-native \
59         stx-fault \
60         openssl \
61         libevent \
62         json-c \
63         "
64 RDEPENDS_${PN}_append = " bash"
65
66 require mtce.inc
67 require inventory.inc
68 require mtce-common.inc
69 require mtce-compute.inc
70 require mtce-control.inc
71 require mtce-storage.inc
72 require python-inventoryclient.inc
73 require pxe-network-installer.inc
74 # require kickstart.inc
75
76 do_configure () {
77         :
78
79
80 do_compile() {
81         :
82 }
83
84 do_install () {
85         :
86 }
87
88 pkg_postinst_ontarget_${PN} () {
89 # install default config files
90 }
91
92 FILES_${PN} = " "
93 FILES_${PN}-dbg_append += " "
94 FILES_${PN}-staticdev_append = " "
95 FILES_${PN}-dev_append = " "
96
97 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"