Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-integ-kubernetes / cloud-provider-openstack.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "cloud-provider-openstack"
17
18 STABLE = "starlingx/master"
19 PROTOCOL = "https"
20 BRANCH = "master"
21 SRCREV = "70609a3d55e5b7d2be82667fc35792505f9013c4"
22 S = "${WORKDIR}/git"
23 PV = "19.05"
24
25 LICENSE = "Apache-2.0"
26
27 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
28
29 SRC_URI = "git://opendev.org/starlingx/config.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 RDEPENDS_${PN} += " bash"
32
33 do_configure () {
34         :
35
36
37 do_compile() {
38         :
39 }
40
41 do_install () {
42
43         cd ${S}/filesystem/cloud-provider-openstack/
44         install -d -m755 ${D}/${bindir}
45         install -d -m755 ${D}/${systemd_system_unitdir}
46
47         install -D -m644 files/cloud-provider-openstack.sh ${D}/${bindir}
48         install -D -m644 files/cloud-provider-openstack.service ${D}/${systemd_system_unitdir}
49
50
51 }
52
53 #pkg_postinst_ontarget_${PN} () {
54 #       /usr/bin/systemctl enable cloud-provider-openstack.service
55 #}      
56
57 FILES_${PN}_append += " \
58                 ${systemd_system_unitdir} \
59                 "