Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-integ / stx-integ.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-integ"
17
18 STABLE = "starlingx/master"
19 PROTOCOL = "https"
20 BRANCH = "r/stx.3.0"
21 SRCNAME = "integ"
22 SRCREV = "0bf4b546df8c7fdec8cfc6cb6f71b9609ee54306"
23 S = "${WORKDIR}/git"
24 PV = "1.0.0"
25
26 LICENSE = "Apache-2.0 & GPL-2.0"
27 LIC_FILES_CHKSUM = " \
28         file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
29         file://base/cgcs-users/cgcs-users-1.0/LICENSE;md5=3c7b4ff77c7d469e869911fde629c35c \
30         file://virt/kvm-timer-advance/files/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
31         file://tools/storage-topology/storage-topology/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
32         "
33
34 SRC_URI = "git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
35         "
36 inherit distutils setuptools
37
38 do_configure () {
39         :
40
41
42 do_compile() {
43         :
44 }
45
46 do_install () {
47         
48 # kvm-timer-advance
49
50         install -p -D -m 0755 ${S}/virt/kvm-timer-advance/files/setup_kvm_timer_advance.sh \
51                         ${D}/${bindir}/setup_kvm_timer_advance.sh
52         install -p -D -m 444 ${S}/virt/kvm-timer-advance/files/kvm_timer_advance_setup.service \
53                         ${D}/${systemd_system_unitdir}/kvm_timer_advance_setup.service
54
55 }
56
57 FILES_${PN} = " "
58
59 PACKAGES += " kvm-timer-advance"
60 DESCRIPTION_kvm-timer-advance = "StarlingX KVM Timer Advance Package"
61
62 RDEPENDS_kvm-timer-advance += " \
63         systemd \
64         bash \
65         "
66 # RDEPENDS_kvm-timer-advance += " bash"
67 FILES_kvm-timer-advance = " \
68         ${bindir}/setup_kvm_timer_advance.sh \
69         ${systemd_system_unitdir}/kvm_timer_advance_setup.service \
70         "