Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-integ / spectre-meltdown-checker_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = " \
17 A shell script to tell if your system is vulnerable against the several \
18 \"speculative execution\" CVEs that were made public since 2018. \
19 "
20
21 SUMMARY = "Spectre and Meltdown Checker"
22 HOMEPAGE = "https://github.com/speed47/spectre-meltdown-checker"
23 LICENSE = "GPL-3.0"
24 LIC_FILES_CHKSUM = "file://spectre-meltdown-checker.sh;beginline=1;endline=5;md5=0113e62a200ec9a5f5ebdd7ad4329133"
25
26 SRCREV = "3d21dae16864f8e8262d7a35bd4de300452b274d"
27 SRCNAME = "spectre-meltdown-checker"
28 BRANCH = "master"
29 PROTOCOL = "https"
30 PV = "v0.43+git${SRCPV}"
31 S = "${WORKDIR}/git"
32
33 SRC_URI = "git://github.com/speed47/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
34
35 do_install() {
36         install -d -p -m 0755 ${D}/${sbindir} 
37         install -m 0644 ${S}/${SRCNAME}.sh ${D}/${sbindir}/${SRCNAME}.sh
38 }
39
40 FILES_${PN} = "${sbindir}/"