ibsh: use the source from stx upstream
[pti/rtp.git] / meta-stx / recipes-core / stx-integ / ibsh_0.3e.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 PROTOCOL = "https"
17 BRANCH = "r/stx.3.0"
18 SRCNAME = "integ"
19 SRCREV = "0bf4b546df8c7fdec8cfc6cb6f71b9609ee54306"
20
21 SRC_URI += "git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH};destsuffix=stx-patches;subpath=base/cgcs-users/cgcs-users-1.0"
22
23 do_patch_append () {
24     bb.build.exec_func('stx_do_patch', d)
25 }
26
27 stx_do_patch () {
28         cd ${S}
29         patch -p1 < ${WORKDIR}/stx-patches/ibsh-0.3e.patch
30         patch -p1 < ${WORKDIR}/stx-patches/ibsh-0.3e-cgcs.patch
31         patch -p1 < ${WORKDIR}/stx-patches/ibsh-0.3e-cgcs-copyright.patch
32 }
33
34 do_install_append() {
35         cp ${WORKDIR}/stx-patches/admin.cmds ${D}/${sysconfdir}/ibsh/cmds/
36         cp ${WORKDIR}/stx-patches/admin.xtns ${D}/${sysconfdir}/ibsh/xtns/
37         cp ${WORKDIR}/stx-patches/operator.cmds ${D}/${sysconfdir}/ibsh/cmds/
38         cp ${WORKDIR}/stx-patches/operator.xtns ${D}/${sysconfdir}/ibsh/xtns/
39         cp ${WORKDIR}/stx-patches/secadmin.cmds ${D}/${sysconfdir}/ibsh/cmds/
40         cp ${WORKDIR}/stx-patches/secadmin.xtns ${D}/${sysconfdir}/ibsh/xtns/
41 }
42