6cd9673865f45cf9e467a1d0cb4791e180ae3013
[pti/rtp.git] / meta-stx / recipes-core / stx-integ / ibsh_0.3e.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17
18 SRC_URI += " \
19         file://${PN}/ibsh-0.3e.patch \
20         file://${PN}/ibsh-0.3e-cgcs.patch \
21         file://${PN}/ibsh-0.3e-cgcs-copyright.patch \
22         file://${PN}/admin.cmds \
23         file://${PN}/admin.xtns \
24         file://${PN}/LICENSE \
25         file://${PN}/operator.cmds \
26         file://${PN}/operator.xtns \
27         file://${PN}/secadmin.cmds \
28         file://${PN}/secadmin.xtns \
29         "
30
31 do_install_append() {
32         cp ${WORKDIR}/${PN}/admin.cmds ${D}/${sysconfdir}/ibsh/cmds/
33         cp ${WORKDIR}/${PN}/admin.xtns ${D}/${sysconfdir}/ibsh/xtns/
34         cp ${WORKDIR}/${PN}/operator.cmds ${D}/${sysconfdir}/ibsh/cmds/
35         cp ${WORKDIR}/${PN}/operator.xtns ${D}/${sysconfdir}/ibsh/xtns/
36         cp ${WORKDIR}/${PN}/secadmin.cmds ${D}/${sysconfdir}/ibsh/cmds/
37         cp ${WORKDIR}/${PN}/secadmin.xtns ${D}/${sysconfdir}/ibsh/xtns/
38 }
39