Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-ha / stx-ha.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-ha"
17
18 PROTOCOL = "https"
19 BRANCH = "r/stx.3.0"
20 SRCNAME = "ha"
21 SRCREV = "a7b7d35b9922a3f2a8462492b7f1958f135a612d"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25
26 #TODO:
27 #3b83ef96387f14655fc854ddc3c6bd57  ./LICENSE
28 #3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt-api/sm-api/LICENSE
29 #3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt-client/LICENSE
30 #1dece7821bf3fd70fe1309eaa37d52a2  ./service-mgmt-client/sm-client/LICENSE
31 #3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt-tools/sm-tools/LICENSE
32 #3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt/LICENSE
33 #3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt/sm-common/LICENSE
34 #3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt/sm-db/LICENSE
35 #3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt/sm/LICENSE
36
37 LICENSE = "Apache-2.0"
38 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
39
40 SRC_URI = "git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
41         file://0001-Allow-user-to-define-destination-libdir.patch \
42         file://0002-Install-sm-eru-sm-eru-dump-and-sm-eru-watchdog.patch \
43         file://0003-pragma-ignore-Wunused-result-errors-with-gcc-8.3.patch \
44         file://0004-Cast-size_t-to-int-to-silence-gcc-8.3.patch \
45         "
46
47 inherit setuptools
48 inherit pkgconfig
49 inherit systemd
50
51 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
52
53 DEPENDS += " \
54         stx-fault \
55         stx-metal \
56         sqlite3 \
57         python \
58         python-pbr-native \
59         glib-2.0 \
60         sqlite3 \
61         "
62
63 require sm-common.inc
64 require sm-db.inc
65 require sm.inc
66 require sm-api.inc
67 require sm-client.inc
68 require sm-tools.inc
69 require stx-ocf-scripts.inc
70
71 #TODO: Shouldn't have to do this
72 LDFLAGS_remove = "-Wl,--as-needed"
73
74 do_configure () {
75         :
76
77
78 do_compile() {
79         :       
80 }
81
82 do_install () {
83         :
84 }
85
86 FILES_${PN} = " "
87 FILES_${PN}-dev += " \
88         var/lib/sm/watchdog/modules/libsm_watchdog_nfs.so \
89         "
90 #       var/lib/sm/watchdog/modules/libsm_watchdog_nfs.so.1 \
91 #       var/lib/sm/watchdog/modules/libsm_watchdog_nfs.so.0 \
92 #       ${libdir}/libsm_common.so.1 \
93 #       ${libdir}/libsm_common.so.0