stx-ha: fix the sqlite related dependencies
[pti/rtp.git] / meta-stx / recipes-core / stx-ha / stx-ha.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-ha"
17
18 PROTOCOL = "https"
19 BRANCH = "r/stx.3.0"
20 SRCNAME = "ha"
21 SRCREV = "a7b7d35b9922a3f2a8462492b7f1958f135a612d"
22 S = "${WORKDIR}/git"
23 PV = "1.0.0"
24
25 LICENSE = "Apache-2.0"
26 LIC_FILES_CHKSUM = " \
27         file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
28         file://service-mgmt-api/sm-api/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
29         file://service-mgmt-client/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
30         file://service-mgmt-client/sm-client/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
31         file://service-mgmt-tools/sm-tools/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
32         file://service-mgmt/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
33         file://service-mgmt/sm-common/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
34         file://service-mgmt/sm-db/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
35         file://service-mgmt/sm/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
36         "
37
38 SRC_URI = "git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
39         file://0001-Allow-user-to-define-destination-libdir.patch \
40         file://0002-Install-sm-eru-sm-eru-dump-and-sm-eru-watchdog.patch \
41         file://0003-pragma-ignore-Wunused-result-errors-with-gcc-8.3.patch \
42         file://0004-Cast-size_t-to-int-to-silence-gcc-8.3.patch \
43         "
44
45 inherit setuptools
46 inherit pkgconfig
47 inherit systemd
48
49 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
50
51 DEPENDS += " \
52         stx-fault \
53         stx-metal \
54         sqlite3 \
55         python \
56         python-pbr-native \
57         glib-2.0 \
58         "
59
60 require sm-common.inc
61 require sm-db.inc
62 require sm.inc
63 require sm-api.inc
64 require sm-client.inc
65 require sm-tools.inc
66 require stx-ocf-scripts.inc
67
68 LDFLAGS_remove = "-Wl,--as-needed"
69
70 do_configure () {
71         :
72
73
74 do_compile() {
75         :       
76 }
77
78 do_install () {
79         :
80 }
81
82 FILES_${PN} = " "
83 FILES_${PN}-dev += " \
84         ${localstatedir}/lib/sm/watchdog/modules/libsm_watchdog_nfs.so \
85         "
86