Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-fault / stx-fault.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-fault"
17
18 INSANE_SKIP_${PN} = "ldflags"
19
20
21 PROTOCOL = "https"
22 BRANCH = "r/stx.3.0"
23 SRCREV = "2025f585c5b92890c8cb32c480b0151c7c1cb545"
24 S = "${WORKDIR}/git"
25 PV = "1.0.0"
26
27 LICENSE = "Apache-2.0"
28
29 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
30
31 SRC_URI = " \
32         git://opendev.org/starlingx/fault.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
33         file://0001-Honor-the-build-system-LDFLAGS.patch \
34         file://0001-Use-build-systems-LDFLAGS.patch \
35         file://0001-snmp-ext-use-build-systems-LDFLAGS.patch \
36         "
37
38 inherit setuptools
39 DEPENDS = " \
40         util-linux \
41         postgresql \
42         python \
43         python-pbr-native \
44         python-six \
45         python-oslo.i18n \
46         python-oslo.utils \
47         python-requests \
48         bash \
49         net-snmp \
50 "
51
52 RDEPENDS_${PN} += " bash"
53
54 cgcs_doc_deploy = "/opt/deploy/cgcs_doc"
55
56 require fm-common.inc
57 require fm-api.inc
58 require fm-doc.inc
59 require fm-mgr.inc
60 require fm-rest-api.inc
61 require python-fmclient.inc
62 require snmp-audittrail.inc
63 require snmp-ext.inc
64
65 do_configure() {
66         :
67 }
68
69 do_compile() {
70         :
71 }
72
73 do_install() {
74         :
75 }
76
77 FILES_${PN} = " "