Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-config / stx-config.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "stx-config"
17
18 PROTOCOL = "https"
19 BRANCH = "r/stx.3.0"
20 SRCREV = "b51e4ef738e0020f11f164fd3f86399872caf3c6"
21 S = "${WORKDIR}/git"
22 PV = "1.0.0"
23
24 LICENSE = "Apache-2.0"
25
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
27
28 SRC_URI = " \
29         git://opendev.org/starlingx/config.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
30         file://0001-stx-config-remove-argparse-requirement-from-sysinv.patch \
31         "
32
33 DEPENDS = "\
34         puppet \
35         python \
36         python-pbr-native \
37         "
38
39 inherit setuptools distutils
40
41 # Other packages depend on tsconfig build it first
42 require tsconfig.inc
43 require config-gate.inc
44 require controllerconfig.inc
45 require storageconfig.inc
46 require cgts-client.inc
47 require sysinv.inc
48 require sysinv-agent.inc
49 require workerconfig.inc
50
51 do_configure() {
52         :
53
54
55 do_compile() {
56         :
57 }
58
59 do_install() {
60         :
61 }
62
63 FILES_${PN} = " "
64
65 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"