pxe-installer-initramfs: add new recipe and add into image
[pti/rtp.git] / meta-stx / recipes-core / pxe-installer-initramfs / pxe-installer-initramfs_1.0.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Provides initramfs used for pxe installer"
17 LICENSE = "Apache-2.0"
18 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
19
20 do_install[depends] += "core-image-anaconda-initramfs:do_image_complete"
21
22 do_install() {
23     install -d ${D}/boot
24     install -m 0644  ${DEPLOY_DIR_IMAGE}/core-image-anaconda-initramfs-${MACHINE}.cpio.gz ${D}/boot/installer-initrd_1.0
25     ln -s installer-initrd_1.0 ${D}/boot/installer-initrd
26 }
27
28 FILES_${PN} = "/boot"