Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / packagegroups / packagegroup-stx.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "StarlingX stx packages"
17
18 PR = "r0"
19
20 #
21 # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
22 #
23
24 PACKAGE_ARCH = "${MACHINE_ARCH}"
25 inherit packagegroup
26
27 PROVIDES = "${PACKAGES}"
28 PACKAGES = " \
29         packagegroup-stx-upstream \
30         packagegroup-stx-puppet \
31         packagegroup-stx-fault \
32         packagegroup-stx-metal \
33         packagegroup-stx-nfv \
34         packagegroup-stx-monitoring \
35         packagegroup-stx-ha \
36         packagegroup-stx-config \
37         packagegroup-stx-config-files \
38         packagegroup-stx-distributedcloud \
39         packagegroup-stx-update \
40         packagegroup-stx-integ \
41         packagegroup-stx-utilities \
42         packagegroup-stx-armada-app \
43         "
44
45 RDEPENDS_packagegroup-stx-puppet = "\
46         stx-puppet \
47         puppet-dcdbsync \
48         puppet-dcmanager \
49         puppet-dcorch \
50         puppet-fm \
51         puppet-mtce \
52         puppet-nfv \
53         puppet-patching \
54         puppet-smapi \
55         puppet-sshd \
56         puppet-sysinv \
57         puppet-manifests \
58         "
59
60 RDEPENDS_packagegroup-stx-config = " \
61         config-gate-worker \
62         config-gate \
63         controllerconfig \
64         cgts-client \
65         sysinv-agent \
66         sysinv \
67         workerconfig-subfunction \
68         tsconfig \
69         "
70
71 RDEPENDS_packagegroup-stx-config-files  = " \
72         audit-config \
73         dhclient-config \
74         dnsmasq-config \
75         docker-config \
76         initscripts-config \
77         filesystem-scripts \
78         haproxy-config \
79         ioscheduler-config \
80         iptables-config \
81         iscsi-initiator-utils-config \
82         lighttpd-config \
83         logrotate-config \
84         memcached-custom \
85         mlx4-config \
86         net-snmp-config \
87         nfs-utils-config \
88         ntp-config \
89         openldap-config \
90         openssh-config \
91         openvswitch-config \
92         pam-config \
93         rabbitmq-server-config \
94         rsync-config \
95         setup-config \
96         shadow-utils-config \
97         sudo-config \
98         syslog-ng-config \
99         systemd-config \
100         util-linux-config \
101         "
102
103 RDEPENDS_packagegroup-stx-fault = " \
104         fm-api \
105         fm-common \
106         fm-doc \
107         fm-mgr \
108         fm-rest-api \
109         python-fmclient \
110         snmp-audittrail \
111         snmp-ext \
112         "
113
114 RDEPENDS_packagegroup-stx-ha = " \
115         sm-common-libs \
116         libsm-common \
117         sm \
118         sm-db \
119         sm-api \
120         sm-client \
121         sm-tools \
122         sm-eru \
123         stx-ocf-scripts \
124         "
125
126 RDEPENDS_packagegroup-stx-metal = " \
127         inventory \
128         mtce \
129         mtce-pmon \
130         mtce-hwmon \
131         mtce-hostw \
132         mtce-lmon \
133         mtce-compute \
134         mtce-control \
135         mtce-storage \
136         python-inventoryclient \
137         pxe-network-installer \
138         "
139
140 RDEPENDS_packagegroup-stx-monitoring = " \
141         collectd-extensions \
142         influxdb-extensions \
143         monitor-tools \
144         vm-topology \
145         "
146
147 RDEPENDS_packagegroup-stx-distributedcloud = " \
148         distributedcloud-dcmanager \
149         distributedcloud-dcorch \
150         distributedcloud-dcdbsync \
151         distributedcloud-ocf \
152         "
153
154 RDEPENDS_packagegroup-stx-nfv = " \
155         nfv-common \
156         nfv-plugins \
157         nfv-tools \
158         nfv-vim \
159         nfv-client \
160         "
161
162 RDEPENDS_packagegroup-stx-upstream = " \
163         barbican \
164         python-neutronclient \
165         python-aodhclient \
166         python-barbican \
167         python-barbicanclient \
168         python-cinderclient \
169         python-glanceclient \
170         python-gnocchiclient \
171         python-django-horizon \
172         python-heatclient \
173         python-ironicclient \
174         python-keystoneauth1 \
175         python-keystoneclient \
176         python-magnumclient \
177         python-muranoclient \
178         python-novaclient \
179         python-openstackclient \
180         python-openstacksdk \
181         python-pankoclient \
182         openstack-ras \
183         "
184
185 RDEPENDS_packagegroup-stx-update = " \
186         cgcs-patch \
187         cgcs-patch-agent \
188         cgcs-patch-controller \
189         enable-dev-patch \
190         patch-alarm \
191         "
192
193 RDEPENDS_packagegroup-stx-integ = " \
194         dpkg \
195         dtc \
196         ibsh \
197         python-redfishtool \
198         puppet-boolean \
199         puppetlabs-create-resources \
200         puppet-dnsmasq \
201         puppet-drbd \
202         puppet-filemapper \
203         puppet-ldap \
204         puppetlabs-lvm \
205         puppet-network \
206         puppet-nslcd \
207         puppetlabs-postgresql \
208         puppet-puppi \
209         mariadb \
210         drbd-utils \
211         docker-distribution \
212         docker-forward-journald \
213         etcd \
214         kubernetes \
215         ldapscripts \
216         python-3parclient \
217         python-lefthandclient \
218         python-setuptools \
219         python-ryu \
220         spectre-meltdown-checker \
221         kvm-timer-advance \
222         ceph \
223         lldpd \
224         lvm2 \
225         tzdata \
226         "
227
228 RDEPENDS_packagegroup-stx-utilities = " \
229         build-info \
230         python-cephclient \
231         ceph-manager \
232         stx-ssl \
233         collector \
234         collect-engtools \
235         logmgmt \
236         namespace-utils \
237         nfscheck \
238         stx-extensions \
239         worker-utils \
240         update-motd \
241         platform-util \
242         pci-irq-affinity \
243         "
244
245 RDEPENDS_packagegroup-stx-armada-app = "\
246         monitor-helm \
247         monitor-helm-elastic \
248         openstack-helm \
249         openstack-helm-infra \
250         stx-monitor-helm \
251         stx-openstack-helm \
252         stx-platform-helm \
253         "