config-files: add starlingx login banners
[pti/rtp.git] / meta-stx / recipes-core / packagegroups / packagegroup-stx.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "StarlingX stx packages"
17
18 PR = "r0"
19
20 #
21 # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
22 #
23
24 PACKAGE_ARCH = "${MACHINE_ARCH}"
25 inherit packagegroup
26
27 PROVIDES = "${PACKAGES}"
28 PACKAGES = " \
29         packagegroup-stx-upstream \
30         packagegroup-stx-puppet \
31         packagegroup-stx-fault \
32         packagegroup-stx-metal \
33         packagegroup-stx-nfv \
34         packagegroup-stx-monitoring \
35         packagegroup-stx-ha \
36         packagegroup-stx-config \
37         packagegroup-stx-config-files \
38         packagegroup-stx-distributedcloud \
39         packagegroup-stx-update \
40         packagegroup-stx-integ \
41         packagegroup-stx-utilities \
42         packagegroup-stx-armada-app \
43         "
44
45 RDEPENDS_packagegroup-stx-puppet = "\
46         stx-puppet \
47         puppet-dcdbsync \
48         puppet-dcmanager \
49         puppet-dcorch \
50         puppet-fm \
51         puppet-mtce \
52         puppet-nfv \
53         puppet-patching \
54         puppet-smapi \
55         puppet-sshd \
56         puppet-sysinv \
57         puppet-manifests \
58         "
59
60 RDEPENDS_packagegroup-stx-config = " \
61         config-gate-worker \
62         config-gate \
63         controllerconfig \
64         cgts-client \
65         sysinv-agent \
66         sysinv \
67         workerconfig-subfunction \
68         tsconfig \
69         "
70
71 RDEPENDS_packagegroup-stx-config-files  = " \
72         audit-config \
73         centos-release-config \
74         dhclient-config \
75         dnsmasq-config \
76         docker-config \
77         initscripts-config \
78         filesystem-scripts \
79         haproxy-config \
80         ioscheduler-config \
81         iptables-config \
82         iscsi-initiator-utils-config \
83         lighttpd-config \
84         logrotate-config \
85         memcached-custom \
86         mlx4-config \
87         net-snmp-config \
88         nfs-utils-config \
89         ntp-config \
90         openldap-config \
91         openssh-config \
92         openvswitch-config \
93         pam-config \
94         rabbitmq-server-config \
95         rsync-config \
96         setup-config \
97         shadow-utils-config \
98         sudo-config \
99         syslog-ng-config \
100         systemd-config \
101         util-linux-config \
102         "
103
104 RDEPENDS_packagegroup-stx-fault = " \
105         fm-api \
106         fm-common \
107         fm-doc \
108         fm-mgr \
109         fm-rest-api \
110         python-fmclient \
111         snmp-audittrail \
112         snmp-ext \
113         "
114
115 RDEPENDS_packagegroup-stx-ha = " \
116         sm-common-libs \
117         libsm-common \
118         sm \
119         sm-db \
120         sm-api \
121         sm-client \
122         sm-tools \
123         sm-eru \
124         stx-ocf-scripts \
125         "
126
127 RDEPENDS_packagegroup-stx-metal = " \
128         inventory \
129         mtce \
130         mtce-pmon \
131         mtce-hwmon \
132         mtce-hostw \
133         mtce-lmon \
134         mtce-compute \
135         mtce-control \
136         mtce-storage \
137         python-inventoryclient \
138         pxe-network-installer \
139         "
140
141 RDEPENDS_packagegroup-stx-monitoring = " \
142         collectd-extensions \
143         influxdb-extensions \
144         monitor-tools \
145         vm-topology \
146         "
147
148 RDEPENDS_packagegroup-stx-distributedcloud = " \
149         distributedcloud-dcmanager \
150         distributedcloud-dcorch \
151         distributedcloud-dcdbsync \
152         distributedcloud-ocf \
153         "
154
155 RDEPENDS_packagegroup-stx-nfv = " \
156         nfv-common \
157         nfv-plugins \
158         nfv-tools \
159         nfv-vim \
160         nfv-client \
161         "
162
163 RDEPENDS_packagegroup-stx-upstream = " \
164         barbican \
165         python-neutronclient \
166         python-aodhclient \
167         python-barbican \
168         python-barbicanclient \
169         python-cinderclient \
170         python-glanceclient \
171         python-gnocchiclient \
172         python-django-horizon \
173         python-heatclient \
174         python-ironicclient \
175         python-keystoneauth1 \
176         python-keystoneclient \
177         python-magnumclient \
178         python-muranoclient \
179         python-novaclient \
180         python-openstackclient \
181         python-openstacksdk \
182         python-pankoclient \
183         openstack-ras \
184         "
185
186 RDEPENDS_packagegroup-stx-update = " \
187         cgcs-patch \
188         cgcs-patch-agent \
189         cgcs-patch-controller \
190         enable-dev-patch \
191         patch-alarm \
192         "
193
194 RDEPENDS_packagegroup-stx-integ = " \
195         dpkg \
196         dtc \
197         ibsh \
198         python-redfishtool \
199         puppet-boolean \
200         puppetlabs-create-resources \
201         puppet-dnsmasq \
202         puppet-drbd \
203         puppet-filemapper \
204         puppet-ldap \
205         puppetlabs-lvm \
206         puppet-network \
207         puppet-nslcd \
208         puppetlabs-postgresql \
209         puppet-puppi \
210         mariadb \
211         drbd-utils \
212         docker-distribution \
213         docker-forward-journald \
214         etcd \
215         kubernetes \
216         ldapscripts \
217         python-3parclient \
218         python-lefthandclient \
219         python-setuptools \
220         python-ryu \
221         spectre-meltdown-checker \
222         kvm-timer-advance \
223         ceph \
224         lldpd \
225         lvm2 \
226         tzdata \
227         "
228
229 RDEPENDS_packagegroup-stx-utilities = " \
230         build-info \
231         python-cephclient \
232         ceph-manager \
233         stx-ssl \
234         collector \
235         collect-engtools \
236         logmgmt \
237         namespace-utils \
238         nfscheck \
239         stx-extensions \
240         worker-utils \
241         update-motd \
242         platform-util \
243         pci-irq-affinity \
244         "
245
246 RDEPENDS_packagegroup-stx-armada-app = "\
247         monitor-helm \
248         monitor-helm-elastic \
249         openstack-helm \
250         openstack-helm-infra \
251         stx-monitor-helm \
252         stx-openstack-helm \
253         stx-platform-helm \
254         "