22a00ecce8743b5061344133ce0695d9ea3d2fe4
[pti/rtp.git] / meta-stx / recipes-core / packagegroups / packagegroup-stak-base.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Base rootfs for stx and akraino"
17
18 PR = "r0"
19
20 #
21 # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
22 #
23
24 PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26
27 inherit packagegroup
28
29 PROVIDES = "${PACKAGES}"
30 PACKAGES = " \
31         packagegroup-stak-base \
32         packagegroup-stak-perl \
33         packagegroup-stak-python \
34         packagegroup-stak-ruby \
35         packagegroup-stak-puppet \
36         "
37
38 RDEPENDS_packagegroup-stak-base = " \
39         lighttpd \
40         tcpdump \
41         tzdata \
42         numactl \
43         samba \
44         mariadb \
45         traceroute \
46         wget \
47         expect \
48         boost \
49         alsa-lib \
50         collectd \
51         conntrack-tools \
52         ding-libs \
53         dosfstools \
54         docker \
55         docker-registry \
56         containerd-opencontainers \
57         dracut \
58         drbd-utils \
59         efibootmgr \
60         efivar \
61         expat \
62         facter \
63         hwdata \
64         iscsi-initiator-utils \
65         isomd5sum \
66         jansson \
67         json-c \
68         kexec-tools \
69         keyutils \
70         kubernetes \
71         libcomerr \
72         libcgroup \
73         libdrm \
74         libedit \
75         libestr \
76         libev \
77         libgudev \
78         libjpeg-turbo \
79         libndp \
80         oath \
81         libogg \
82         libpcap \
83         libpciaccess \
84         libpipeline \
85         libpng \
86         libproxy \
87         libpwquality \
88         libseccomp \
89         libsm \
90         libss \
91         libssh2 \
92         libtomcrypt \
93         libtommath \
94         sysfsutils \
95         libteam \
96         libuser \
97         libutempter \
98         libvorbis \
99         cyrus-sasl \
100         ipmitool \
101         iperf3 \
102         iotop \
103         lsof \
104         lsscsi \
105         lz4 \
106         lzop \
107         lz4 \
108         lzop \
109         mailcap \
110         mailx \
111         mdadm \
112         mod-wsgi \
113         mokutil \
114         mozjs \
115         mtools \
116         mysql-python \
117         libnewt-python \
118         nmap \
119         nss-pam-ldapd \
120         ntfs-3g-ntfsprogs \
121         openipmi \
122         openldap \
123         libopus \
124         ovmf-shell-efi \
125         p11-kit \
126         perf \
127         polkit \
128         popt \
129         procps \
130         pulseaudio \
131         screen \
132         seabios \
133         smartmontools \
134         snappy \
135         socat \
136         spawn-fcgi \
137         spice \
138         swig \
139         sysstat \
140         tcp-wrappers \
141         trousers \
142         xfsprogs \
143         yajl \
144         zip \
145         c-ares \
146         cifs-utils \
147         createrepo-c \
148         gdbm \
149         gmp \
150         groff \
151         libnl \
152         mcstrans \
153         linuxptp \
154         lua \
155         lldpd \
156         multipath-tools \
157         flac \
158         freetype \
159         geoip \
160         glusterfs \
161         gobject-introspection \
162         gperftools \
163         gperftools \
164         gpm \
165         hiera \
166         leveldb \
167         libutempter \
168         lksctp-tools \
169         quota \
170         radvd \
171         usbredir \
172         texinfo \
173         freetype \
174         celt051 \
175         cryptsetup \
176         lmsensors-libsensors \
177         lmsensors-fancontrol \
178         lmsensors-isatools \
179         lmsensors-pwmconfig \
180         lmsensors-sensord \
181         lmsensors-sensors \
182         lmsensors-sensorsconfconvert \
183         lmsensors-sensorsdetect \
184         syslinux \
185         krb5 \
186         rocksdb \
187         resource-agents \
188         go-phercloud \
189         haproxy \
190         cluster-glue \
191         dpkg \
192         eventlog \
193         libibverbs \
194         libnfsidmap \
195         net-tools \
196         hardlink \
197         deltarpm \
198         dtc \
199         dtc-dev \
200         libtpms \
201         nscd \
202         openscap \
203         polkit \
204         "
205 #       libibverbs Conflicts with rdma-core
206 #       qat17 
207 #       docker-distribution 
208
209 RDEPENDS_packagegroup-stak-ruby = " \
210         ruby-shadow \
211         ruby \
212         "
213
214 RDEPENDS_packagegroup-stak-puppet = " \
215         puppet \
216         puppet-vswitch \
217         "
218
219 RDEPENDS_packagegroup-stak-perl = " \
220         filter-perl \
221         pathtools-perl \
222         podlators-perl \
223         scalar-list-utils-perl \
224         \
225         perl-module-carp \
226         perl-module-constant \
227         perl-module-data-dumper \
228         perl-module-encode \
229         perl-module-exporter \
230         perl-module-file-path \
231         perl-module-file-temp \
232         perl-module-getopt-long \
233         perl-module-http-tiny \
234         perl-module-parent \
235         perl-module-pod-escapes \
236         perl-module-pod-perldoc \
237         perl-module-pod-simple \
238         perl-module-pod-usage \
239         perl-module-socket \
240         perl-module-storable \
241         perl-module-text-parsewords \
242         perl-module-time-local \
243         perl-module-time-hires \
244         perl-module-threads \
245         perl-module-threads-shared \
246         filter-perl \
247         libhtml-tagset-perl \
248         libmailtools-perl \
249         libsocket6-perl \
250         libtest-pod-perl \
251         libwww-perl \
252         pathtools-perl \
253         scalar-list-utils-perl \
254         "
255
256 RDEPENDS_packagegroup-stak-python = " \
257         python-pygpgme \
258         python-pyparted \
259         python-coverage \
260         python-docker-registry-core \
261         python-flask-restful \
262         python-mox3 \
263         python-pexpect \
264         python-ptyprocess \
265         python-traceback2 \
266         python-typing \
267         python-ujson \
268         python-yappi \
269         python-hp3parclient \
270         python-click \
271         python-daemon \
272         python-ipy \
273         python-ldap \
274         python-linecache2 \
275         python-pep8 \
276         python-pyudev \
277         python-simplegeneric \
278         python-slip-dbus \
279         python-pytz \
280         python-pymysql \
281         python-pyzmq \
282         python-xstatic-jquery.tablesorter \
283         python-xstatic-jquery.quicksearch \
284         python-xstatic-magic-search \
285         python-pyperf \
286         python-urwid \
287         python-urlgrabber \
288         python-semantic-version \
289         python-repoze.lru \
290         python-pyelftools \
291         python-pycurl \
292         python-lefthandclient \
293         python-jwcrypto \
294         python-iniparse \
295         python-ethtool \
296         python-jmespath \
297         python-beaker \
298         python-cherrypy \
299         python-d2to1 \
300         python-firewall \
301         python-ldap3 \
302         python-pyngus \
303         python-pyzmq \
304         python-requests-oauthlib \
305         python-versiontools \
306         python-dogpile.cache \
307         python-oslo.cache \
308         python-oslo.concurrency \
309         python-oslo.config \
310         python-oslo.context \
311         python-oslo.db \
312         python-oslo.i18n \
313         python-oslo.log \
314         python-oslo.middleware \
315         python-oslo.messaging \
316         python-oslo.policy \
317         python-oslo.rootwrap \
318         python-oslo.serialization \
319         python-oslo.service \
320         python-oslo.upgradecheck \
321         python-oslo.utils \
322         python-oslo.versionedobjects \
323         python-configobj \
324         python-pyudev \
325         python-six \
326         python-alembic \
327         python-django-debreach \
328         python-google-auth \
329         python-gunicorn \
330         python-influxdb \
331         python-ldappool \
332         python-munch \
333         python-aniso8601 \
334         python-yaql \
335         python-construct \
336         python-yappi \
337         python-idna \
338         python-selectors34 \
339         python-pymisp \
340         python-scrypt \
341         python-flask \
342         python-itsdangerous \
343         python-flask-sqlalchemy \
344         python-funcsigs \
345         python-requests \
346         python-pymongo \
347         python-pytest-tempdir \
348         python-flask-migrate \
349         python-robotframework \
350         python-webencodings \
351         python-flask-nav \
352         python-lockfile \
353         python-pluggy \
354         python-configparser \
355         python-dateutil \
356         python-enum34 \
357         python-monotonic \
358         python-humanize \
359         python-unidiff \
360         python-snakefood \
361         python-traceback2 \
362         python-babel \
363         python-jsonpatch \
364         python-cmd2 \
365         python-pyusb \
366         python-strict-rfc3339 \
367         python-robotframework-seriallibrary \
368         python-sijax \
369         python-click \
370         python-zopeinterface \
371         python-parse-type \
372         python-semver \
373         python-bcrypt \
374         python-typing \
375         python-flask-bcrypt \
376         python-pynetlinux \
377         python-pyasn1-modules \
378         python-pyfirmata \
379         python-cryptography \
380         python-flask-babel \
381         python-urllib3 \
382         python-protobuf \
383         python-slip-dbus \
384         python-singledispatch \
385         python-pycodestyle \
386         python-blinker \
387         python-beautifulsoup4 \
388         python-pyalsaaudio \
389         python-sh \
390         python-mako \
391         python-backports-abc \
392         python-flask-script \
393         python-flask-bootstrap \
394         python-asn1crypto \
395         python-pysqlite \
396         python-pybind11 \
397         python-greenlet \
398         python-attr \
399         python-daemon \
400         python-pydbus \
401         python-lazy-object-proxy \
402         python-crcmod \
403         python-pytest \
404         python-pytest-runner \
405         python-pandas \
406         python-pyinotify \
407         python-flask-wtf \
408         python-daemonize \
409         python-wtforms \
410         python-pyiface \
411         python-pretend \
412         pyrtm \
413         python-ipaddress \
414         python-bitarray \
415         python-pyflakes \
416         python-snimpy \
417         python-pysnmp \
418         python-pyjwt \
419         python-hyperlink \
420         python-sdnotify \
421         python-rfc3987 \
422         python-vobject \
423         python-serpent \
424         python-mccabe \
425         python-py \
426         python-speaklater \
427         python-intervals \
428         python-flask-mail \
429         python-ndg-httpsclient \
430         python-wcwidth \
431         python-pyparsing \
432         python-pep8 \
433         python-redis \
434         python-psutil \
435         python-grpcio-tools \
436         python-flask-restful \
437         python-mock \
438         python-javaobj-py3 \
439         python-subprocess32 \
440         python-constantly \
441         python-netaddr \
442         python-pam \
443         python-stevedore \
444         python-dbusmock \
445         python-matplotlib \
446         python-attrs \
447         python-docutils \
448         python-pyopenssl \
449         python-setuptools-scm \
450         python-smbus \
451         python-dnspython \
452         python-pycparser \
453         python-pyserial \
454         python-imaging \
455         python-pint \
456         python-cython \
457         python-flask-login \
458         python-html5lib \
459         python-flask-xstatic \
460         python-chardet \
461         python-flask-uploads \
462         python-inflection \
463         python-twofish \
464         python-pytz \
465         python-jsonschema \
466         python-flask-user \
467         python-behave \
468         python-pyzmq \
469         python-jinja2 \
470         python-pyasn1 \
471         python-pyudev \
472         python-sparts \
473         python-epydoc \
474         python-feedparser \
475         python-pyrex \
476         python-progress \
477         python-can \
478         python-vcversioner \
479         python-markupsafe \
480         python-paho-mqtt \
481         python-grpcio \
482         python-xlrd \
483         python-visitor \
484         python-pyflame \
485         python-jsonpointer \
486         python-numeric \
487         python-ptyprocess \
488         python-pyperclip \
489         python-wrapt \
490         python-appdirs \
491         python-cheetah \
492         python-dbus \
493         python-flask-sijax \
494         python-simplejson \
495         python-webdav \
496         python-pip \
497         python-oauthlib \
498         python-flask-pymongo \
499         python-sqlalchemy \
500         python-django \
501         python-pbr \
502         python-networkx \
503         python-decorator \
504         python-anyjson \
505         python-prompt-toolkit \
506         python-pycrypto \
507         python-cffi \
508         python-djangorestframework \
509         python-future \
510         python-linecache2 \
511         python-pyroute2 \
512         python-parse \
513         python-feedformatter \
514         python-pysocks \
515         python-six \
516         python-alembic \
517         python-pybluez \
518         python-pysmi \
519         python-gdata \
520         python-gevent \
521         python-whoosh \
522         python-ujson \
523         python-xstatic-font-awesome \
524         python-pexpect \
525         python-iso8601 \
526         python-flask-navigation \
527         python-pystache \
528         python-lxml \
529         python-prettytable \
530         python-systemd \
531         python-cryptography-vectors \
532         python-pyhamcrest \
533         python-certifi \
534         python-ply \
535         python-webcolors \
536         python-editor \
537         python-django-south \
538         pamela \
539         python-aws-iot-device-sdk-python \
540         python-werkzeug \
541         python-isort \
542         python-periphery \
543         python-pytest-helpers-namespace \
544         python-paste \
545         python-pyyaml \
546         python-dominate \
547         python-pygpgme \
548         python-msgpack \
549         python-xstatic \
550         python-evdev \
551         python-passlib \
552         python-horizon \
553         python-keyring \
554         python-pyinotify \
555         python3-linux-procfs \
556         python-murano-pkg-check \
557         python-oslo.upgradecheck \
558         python-xstatic-term.js \
559         python-configshell \
560         "
561
562 #       python-dogpile.core