stx-image-aio: inherit extrausers-config in image recipe
[pti/rtp.git] / meta-stx / recipes-core / images / stx-image-aio.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = " StarlingX Single Server"
17
18 LICENSE = "MIT"
19
20 CORE_IMAGE_EXTRA_INSTALL = " \
21         packagegroup-basic \
22         packagegroup-core-base-utils  \
23         "
24
25 IMAGE_INSTALL_append = " \
26         ${CORE_IMAGE_BASE_INSTALL} \
27         packagegroup-core-full-cmdline \
28         packagegroup-core-lsb \
29         packagegroup-stx-upstream \
30         packagegroup-stx-puppet \
31         packagegroup-stx-fault \
32         packagegroup-stx-metal \
33         packagegroup-stx-nfv \
34         packagegroup-stx-monitoring \
35         packagegroup-stx-ha \
36         packagegroup-stx-config-files \
37         packagegroup-stx-update \
38         packagegroup-stx-integ \
39         packagegroup-stx-config \
40         packagegroup-stx-distributedcloud \
41         packagegroup-stx-utilities \
42         packagegroup-stx-armada-app \
43         starlingx-dashboard \
44         playbookconfig \
45         distributedcloud-client-dcmanager \
46         registry-token-server \
47         "
48
49 IMAGE_FEATURES += " \
50         package-management \
51         ssh-server-openssh \
52         "
53
54 inherit stx-postrun
55 inherit extrausers-config
56 inherit core-image
57 inherit distro_features_check
58 inherit openstack-base
59 inherit identity
60 inherit monitor
61
62 # We need docker-ce
63 PACKAGE_EXCLUDE += " docker"