classes: add stx-image-list.bbclass to generate pkglist
[pti/rtp.git] / meta-stx / recipes-core / images / stx-image-aio-installer.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "An image with Anaconda to do installation for StarlingX"
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
20
21 # Support installation from initrd boot
22 do_image_complete[depends] += "core-image-anaconda-initramfs:do_image_complete"
23
24 DEPENDS += "isomd5sum-native"
25
26 CUSTOMIZE_LOGOS ??= "yocto-compat-logos"
27
28 # We override what gets set in core-image.bbclass
29 IMAGE_INSTALL = "\
30     packagegroup-core-boot \
31     packagegroup-core-ssh-openssh \
32     ${@['', 'packagegroup-installer-x11-anaconda'][bool(d.getVar('XSERVER', True))]} \
33     python3-anaconda \
34     anaconda-init \
35     kernel-modules \
36     ${CUSTOMIZE_LOGOS} \
37     dhcp-client \
38     ldd \
39     rng-tools \
40     gptfdisk \
41     pxe-installer-initramfs \
42 "
43
44 IMAGE_LINGUAS = "en-us en-gb"
45
46 # Generate live image
47 IMAGE_FSTYPES_remove = "wic wic.bmap"
48 IMAGE_FSTYPES_append = " iso"
49
50 IMAGE_ROOTFS_EXTRA_SPACE =" + 102400"
51
52 inherit core-image stx-anaconda-image
53
54 KICKSTART_FILE ?= "${LAYER_PATH_meta-stx}/conf/distro/files/ks/poky_stx_aio_ks.cfg"
55
56 # Only the ones prefix with poky_stx_ are tested and working
57 KICKSTART_FILE_EXTRA ?= " \
58     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/poky_stx_aio_ks.cfg \
59     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/aio_ks.cfg \
60     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/aio_lowlatency_ks.cfg \
61     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/controller_ks.cfg \
62     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/net_controller_ks.cfg \
63     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/net_smallsystem_ks.cfg \
64     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/net_smallsystem_lowlatency_ks.cfg \
65     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/net_storage_ks.cfg \
66     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/net_worker_ks.cfg \
67     ${LAYER_PATH_meta-stx}/conf/distro/files/ks/net_worker_lowlatency_ks.cfg \
68 "
69
70 SYSLINUX_CFG_LIVE = "${LAYER_PATH_meta-stx}/conf/distro/files/syslinux.cfg"