Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / distributedcloud / distributedcloud-client-dcmanager_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = " \
17         Client library for Distributed Cloud built on the Distributed Cloud API. \
18         It provides a command-line tool (dcmanager).  \
19         Distributed Cloud provides configuration and management of distributed clouds \
20         "
21
22 HOMEPAGE = "https://opendev.org/starlingx"
23 SECTION = "network"
24 LICENSE = "Apache-2.0"
25 LIC_FILES_CHKSUM = "file://distributedcloud-client/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
26
27 PROTOCOL = "https"
28 BRANCH = "r/stx.3.0"
29 SRCNAME = "distcloud-client"
30 SRCREV = "8a8f01dd3701d4793dd8cbc0147e4dca49cd7c03"
31 PV = "1.0.0+git${SRCPV}"
32 S = "${WORKDIR}/git"
33
34 SRC_URI = " \
35         git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
36         "
37
38 inherit distutils python-dir
39
40 DEPENDS += " \
41         python-pbr-native \
42         "
43
44 do_configure() {
45         cd ${S}/distributedcloud-client
46         distutils_do_configure
47 }
48
49 do_compile() {
50         cd ${S}/distributedcloud-client
51         distutils_do_compile
52 }
53
54 do_install() {
55         cd ${S}/distributedcloud-client
56         distutils_do_install
57 }