Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-containers / kubernetes / helm_2.13.1.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "The Kubernetes Package Manager"
17 HOMEPAGE = "https://github.com/kubernetes/helm/releases "
18 SECTION = "devel"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=0c7bcb474e766c7d92924a18cd9d3878"
21
22 #SRCREV = "618447cbf203d147601b4b9bd7f8c37a5d39fbb4"
23 SRCNAME = "helm"
24 #PROTOCOL = "https"
25 #BRANCH = "release-2.13"
26 S = "${WORKDIR}/linux-amd64"
27 PV = "2.13.1"
28
29 SRC_URI = " \
30         https://get.helm.sh/helm-v2.13.1-linux-amd64.tar.gz \
31         file://helm-upload \
32         file://helm.sudo \
33         "
34 # Client: &version.Version{SemVer:"v2.13.1", GitCommit:"618447cbf203d147601b4b9bd7f8c37a5d39fbb4", GitTreeState:"clean"}
35 SRC_URI[md5sum] = "ffbe37fe328d99156d14a950bbd8107c"
36 SRC_URI[sha256sum] = "c1967c1dfcd6c921694b80ededdb9bd1beb27cb076864e58957b1568bc98925a"
37
38 INSANE_SKIP_${PN} = "ldflags"
39 INHIBIT_PACKAGE_STRIP = "1"
40 INHIBIT_SYSROOT_STRIP = "1"
41 INHIBIT_PACKAGE_DEBUG_SPLIT  = "1"
42
43 RDEPENDS_${PN} += " bash"
44
45
46 do_configure() {
47         :
48 }
49
50 do_compile() {
51         :
52 }
53
54 do_install() {
55         install -m 0755 -d ${D}/${sbindir}/
56         install -m 0750 -d ${D}/${sysconfdir}/sudoers.d
57
58         install -m 0755 ${S}/helm ${D}/${sbindir}/
59         install -m 0755 ${S}/../helm.sudo ${D}/${sysconfdir}/sudoers.d/helm
60         install -m 0755 ${S}/../helm-upload ${D}/${sbindir}/
61 }
62
63 BBCLASSEXTEND = "native nativesdk"
64
65 FILES_${PN} = " \
66         ${sbindir}/helm \
67         ${sbindir}/helm-upload \
68         ${sysconfdir}/sudoers.d \
69         ${sysconfdir}/sudoers.d/helm \
70         "