Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-containers / docker-distribution / docker-distribution_git.bbappend
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 PKG_NAME = "github.com/docker/distribution"
17
18 SYSROOT_PREPROCESS_FUNCS += "docker_distribution_sysroot_preprocess"
19
20 docker_distribution_sysroot_preprocess () {
21     install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
22     cp -r ${S} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
23 }