Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-connectivity / openssl / openssl10_1.0.%.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SYSROOT_DIRS_BLACKLIST = " ${bindir} ${sysconfdir}"
17
18 SYSROOT_PREPROCESS_FUNCS += "openssl10_avoid_conflict"
19
20 openssl10_avoid_conflict () {
21
22        # For libaries remove statics and symlinks to avoid conflict
23
24         rm ${SYSROOT_DESTDIR}${libdir}/libssl.so
25         rm ${SYSROOT_DESTDIR}${libdir}/libcrypto.so
26         rm ${SYSROOT_DESTDIR}${libdir}/libssl.a
27         rm ${SYSROOT_DESTDIR}${libdir}/libcrypto.a
28         #mv ${SYSROOT_DESTDIR}${libdir}/pkgconfig/libcrypto.pc ${SYSROOT_DESTDIR}${libdir}/pkgconfig/libcrypto10.pc 
29         #mv ${SYSROOT_DESTDIR}${libdir}/pkgconfig/libssl.pc ${SYSROOT_DESTDIR}${libdir}/pkgconfig/libcrypto10.pc 
30         #mv ${SYSROOT_DESTDIR}${libdir}/pkgconfig/openssl.pc ${SYSROOT_DESTDIR}${libdir}/pkgconfig/openssl10.pc 
31         rm -rf ${SYSROOT_DESTDIR}${libdir}/pkgconfig
32         rm -rf ${SYSROOT_DESTDIR}${libdir}/engines 
33         # For headers
34         mkdir -p ${SYSROOT_DESTDIR}${includedir}/openssl10
35         mv ${SYSROOT_DESTDIR}${includedir}/openssl ${SYSROOT_DESTDIR}${includedir}/openssl10
36 }