Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-connectivity / libnfsidmap / libnfsidmap_0.25.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "NFS id mapping library"
17 HOMEPAGE = "http://www.citi.umich.edu/projects/nfsv4/linux/"
18 SECTION = "libs"
19
20 LICENSE = "BSD"
21 LIC_FILES_CHKSUM = "file://COPYING;md5=d9c6a2a0ca6017fda7cd905ed2739b37"
22
23 SRC_URI = "http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${BPN}-${PV}.tar.gz \
24            file://fix-ac-prereq.patch \
25            file://Set_nobody_user_group.patch \
26            file://0001-include-sys-types.h-for-getting-u_-typedefs.patch \
27           "
28
29 SRC_URI[md5sum] = "2ac4893c92716add1a1447ae01df77ab"
30 SRC_URI[sha256sum] = "656d245d84400e1030f8f40a5a27da76370690c4a932baf249110f047fe7efcf"
31
32 UPSTREAM_CHECK_URI = "http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/"
33
34 inherit autotools
35
36 EXTRA_OECONF = "--disable-ldap"
37
38 do_install_append () {
39         install -d ${D}${sysconfdir}/
40         install -m 0644 ${WORKDIR}/${BPN}-${PV}/idmapd.conf ${D}${sysconfdir}/idmapd.conf
41 }
42