Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-connectivity / etcd / etcd_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17 SRC_URI += " \
18     file://etcd.service \
19     file://etcd.conf \
20     "
21
22 SYSTEMD_PACKAGES = "${PN}"
23 SYSTEMD_SERVICE_${PN} = "etcd.service"
24 SYSTEMD_AUTO_ENABLE_${PN} = "disable"
25
26 do_install_append() {
27         install -m 0644 ${WORKDIR}/etcd.service ${D}${systemd_system_unitdir}
28         install -d ${D}${sysconfdir}/etcd
29         install -m 0644 ${WORKDIR}/etcd.conf ${D}${sysconfdir}/etcd
30 }